Stormbound: Kingdom Wars Wiki
Advertisement

This article is a stub. You can help Stormbound: Kingdom Wars Wiki by expanding it.

The following are system requirements for Stormbound: Kingdom Wars. While these requirements do not represent a guaranteed working configuration, meeting the minimum requirements should ensure at least a launch-able environment.

Requirements[]

Android iPhone
Android 4.3 and up iOS 8.0 or later. Compatible with iPhone, iPad and iPod touch.

See also[]

Advertisement